Skip to content. | Skip to navigation

IT Virtualization Blog

Personal tools

This is SunRain Plone Theme
You are here: Home / Users / lmarzke / Alfresco 3.4a community on Ubuntu 10.04

Alfresco 3.4a community on Ubuntu 10.04

by lmarzke last modified Dec 18, 2010 12:18 PM
Howto install Alfresco 3.4a Community on Ubuntu 10.04 server - Lee Marzke

see Also:  Alfresco 3.4a on CentOS 5.5 64 bit

Installation

 I'm installing to Vsphere 4.0 on ESX 4.0, BTW.

Please send any errors/comments to lmarzke [at] 4aero [.] com

 

Steps

  1. Install Ubuntu from the server 64-bit distribution.
  2. Install all updates
    yum update
  3. Install build tools and Install dependencies
    aptitude update
    aptitude install build-essential
    aptitude install zlib1g-dev libjpeg62-dev libfreetype6-dev
  4. For some reason the Alfresco included swftools package doesn't run.  I just compiled a fresh version
    cd /usr/local/src/
    wget http://www.swftools.org/swftools-0.9.1.tar.gz
    tar -xzvf swftools...
    cd swftools
    ./configure
    make
    make install
  5. ImageMagick supplied with Alfresco doesn't work.  Install from Ubuntu repos.
    aptitude install imagemagick

    Then replace Alfresco supplied ImageMagick binary and libs with the Ubuntu versions.

    cd /opt/alfreso-3.4a/common/bin/
    mv .convert.bin .convert.bin.orig
    ln -s /usr/bin/convert .convert.bin
    cd ../lib
    mkdir bak
    mv libMag* bak
    ln -s /usr/lib/libMag* .
  6. Update Alfresco to use the new swftools and ImageMagick
    vi /opt/alfresco/tomcat/shared/classes/alfresco-global.properties
    change lines as follows:
    - swf.exe=/opt/alfresco-3.4.a/common/bin/pdf2swf
    + swf.exe=/usr/local/bin/pdf2swf
    
    - img.exe=${img.root}/bin/convert
    + img.exe=/usr/local/bin/convert
  7. Fix email configuration per
    http://issues.alfresco.com/jira/browse/ALF-2688


    And add the following settings to
    /opt/alfresco/tomcat/shared/classes/alfresco-global.properties
    #                                                                                                                         
    # Outbound Email Configuration                                                                                            
    #-------------                                                                                                            
    mail.host=mail.yourhost.com
    mail.port=25
    mail.username=username
    mail.password=password
    mail.encoding=UTF-8
    mail.from.default=user@example.com
    mail.smtp.auth=fals

  8. Change the following settings in
    /opt/alfresco/tomcat/shared/classes/alfresco-global.properties

    -  img.root=/opt/alfresco34a/common
    +  img.root=/usr
    as suggested here.

 

 

Notes

  1. This installer runs mysql, OO, and alfresco as root.    Not very suitable for usage on the Internet !   I'll try fixing this later.

  2. I would like to run behind Apache using mod_jk or Apache re-write rules.  To be added later.

 

 

 

Document Actions